Как определить версию интерпретатора PHP

Форум для тех кто начинает осваивать язык php.
Force
Сообщения: 35
Благодарил (а): 1 раз

Как определить версию интерпретатора PHP

Сообщение Force » Ср ноя 25, 2015 11:47 am

Версию интерпретатора необходимо знать, что бы знать, как писать код.
- Что это значит?
- Ну, например в php 5.3, массив пишется так:

Код: Выделить всё

$array = array(1, 2, 3, 4, 5);

А в php 5.4, массив можно писать так:

Код: Выделить всё

$array = [1, 2, 3, 4, 5];

Прямо, как в JavaScript!
Разумеется написание массива не единственная разница версий php, в новые версии добавляют новые функции, а какие-то убирают. По этому и необходимо знать версию своего интерпретатора PHP.

Определить версию интерпретатора PHP, можно функцией phpinfo(). Эта функция много чего покажет, но то, что нам нужно, покажет в самом верху: PHP Version 5.3.x.

Второе. Определить версию интерпретатора PHP, при помощи функции phpversion(). Эта функция предназначена только для этого, других параметров php она не "знает".

Для того, что бы воспользоваться функцией phpinfo(), не нужны функции для вывода информации на экран (echo или print), делается так:

Код: Выделить всё

<?php
phpinfo();

А вот получить информацию от функции phpversion() необходимо делать так:

Код: Выделить всё

<?php
echo phpversion();

И всё у вас получится!
Реклама

Вернуться в «PHP»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость