При добавлении видео с YouTube выходит ошибка

Форум поддержки движка социальной сети phpFOX.
Аватара пользователя
Slash
Администратор
Сообщения: 2121
Зарегистрирован: Сб авг 11, 2012 7:39 am
Поблагодарили: 74 раза

При добавлении видео с YouTube выходит ошибка

Сообщение Slash » Пт окт 09, 2015 8:55 am

На версии phpFOX 3.8.0 при добавлении видео с YouTube получил белую, пустую страницу.
Решение было найдено тут: http://store.phpfox.com/announcement/fi ... ort-issues
Значит, открываем: module/video/include/service/grab.class.php, находим:

Код: Выделить всё

            if (strpos($sUrl, 'youtube') || (preg_match('/http:\/\/youtu\.be\/(.*)/i', $sUrl, $aMatches) && isset($aMatches[1]))) 
            {
                $this->_aRegex = false;
                $this->_aSites = $this->_aSiteCache;
                if (isset($aMatches) && $aMatches[1])
                {
                    $sUrl = 'http://www.youtube.com/watch?v=' . $aMatches[1];
                }                
            } 
меняем на:

Код: Выделить всё

            if (strpos($sUrl, 'youtube') || (preg_match('/(http|https):\/\/youtu\.be\/(.*)/i', $sUrl, $aMatches) && isset($aMatches[2])))
            {
                $this->_aSites = $this->_aSiteCache;
                if (isset($aMatches) && $aMatches[2])
                {
                    $sUrl = 'http://www.youtube.com/watch?v=' . $aMatches[2];
                }
            } 
Сохраняем. Готово!

Реклама

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость